Alienware 15 R2 crashes then doesn't turn on

Alienware 15 R2 crashes then doesn't turn on

  • 84

bluedino

Hi,
I was using google chrome and suddenly my laptop has turn off completely. I just turned it back on then few minutes later it turn off again, but now I can't turn it on. There's no light no sound, nothing.

Edited

Replies 3

jim_survak

I've seen, on a rare occasion, where the little capacitors on laptop boards get overcharged & run distribute power to the system properly. Unplug the power cable & follow the instructions in the service manual (if you feel confident enough) starting on page 132.

https://downloads.dell.com/manuals/all-products/esuprt_laptop/esuprt_alienware_laptops/alienware-15-r2_service%20manual_en-us.pdf

Once the battery is disconnected (you don't need to fully remove it from the case, just disconnect the plug from the board), hold the power button down for about 10 seconds. Then plug in the power cable & see if it powers on. If it does, reconnect the battery & carry on. Run a diagnostic afterward if you want.

Let us know if this helps.

No Alienware system at present, saving up for another 13/15"

MogRules edited

Is there a light on your adapter? Is it turning off when you plug the adapter into the system? If there is a light and it goes out when you plug the brick in then it could indicate a serious problem with the motherboard, more then likely a short.  If the light does not go out then it could indicate another issue.  

 

Try what Jim_Survak suggested and let us know. 

 

Alienware 17R4 / 7820HK / GTX1080 / 16Gb DDR4 / 512gb M.2 NVMe , 1tb SATA SSD, 1tb SATA M.2

CloudStorm

Hey,

I have already went through this, your best bet is to check the Ac adapter and if its fine, your battery is most likely dead and needs to be replaced. The dell support will try to sell you the refurbished battery if you happen to call them and note the battery is not covered in warranty.

Also, you can connect you Ac adapter and turn on the system, if it doesnt turn on, just unplug the battery and use only the  Ac adapter to see if system is working fine.

Hope your System Revives !!


You must be logged in to comment.