M17x battery not charging?

M17x battery not charging?

  • 54

The_Goth_Rat

hi i'm not sure whats up, but the power cord is plugged in but its not charging the battery and when you click on the battery icon it says that same thing "pluged in, not charging" so whats up is their something wrong with my battery or did i switch somthing off?? any HELP please

Replies 20

dvsman

Is it the stock power adaptor? I know my M17x is sometimes finicky about the power supply. Most times it will detect it as a real DELL power adaptor but once in a blue moon, it will say non-Dell power adaptor and refuse to recharge. If that is the case, I would definitely call it in while I still had warranty coverage. Good luck!

The_Goth_Rat

dvsman said:

Is it the stock power adaptor? I know my M17x is sometimes finicky about the power supply. Most times it will detect it as a real DELL power adaptor but once in a blue moon, it will say non-Dell power adaptor and refuse to recharge. If that is the case, I would definitely call it in while I still had warranty coverage. Good luck!

yeah actually now you mention it it did say a few times that it did not reconise the adapter about 2 months ago but then it started working again shortly after so i figured it was just a one off now this with the "pluged in, not charging" thing it must be what you say :3 thanks for your help mate i'll be calling dell up ASAP :3

Thumper_6119

I was having a problem with my battery charging.  While the machine was on, I popped the battery out, waited 10 seconds, then put it back in.  It worked fine, and it hasn't had a problem since.

vesdawg20

I had the same problem a week after receiving my Mx17. I freaked out. I called Dell, and the technician told me to turn the laptop off, disconnect the power cables, take out the battery, and then hold the power button down for a full minute. This will fully drain the power supply. Put the battery back in, plug in the power supply and power up. I've had to do this twice and it has worked both times. Still not sure what causes it, however.

dvsman

I don't have my M17x with me but my M11x has a bios option for disabling power supply detection. I can't remember seeing this option in the M17 or not, so you might want to check for that also.

browncw99

According to Alienware Support, this is a known issue and they are working on a fix for the next BIOS update. To get the machine to recognize the power supply, when the machine starts and reports an unrecognized power supply, hit F2 to go into the BIOS setup, unplug the power supply and then plug it back in, then exit BIOS without machine any changes. This will let the machine recognize the power supply.

Kickimanjaro

I had this problem with my M15x. I would recommend calling support to get an official answer, but here's how I fixed it myself: 1) Turn off computer 2) Disconnect all peripherals from computer (everything) 3) Hold the power button for 15 seconds 4) Plug it into power and restart I also ended up upgrading my BIOS upon recommendation from the Dell Support Technician, however there is something that is VERY important to note if you do this: AFTER UPGRADING THE BIOS, DO NOT INSTALL THE VERSION OF COMMAND CENTER FROM THE RESOURCE DVD -- It will break the lighting effects and require a repair (this happened to me and I will be sending it in for repair...eventually).

Karosuu

Did You tried Pressing the key: Fn + F2 to activate or diactivate the battery charging mode?

Kickimanjaro

Karosuu said:

Did You tried Pressing the key: Fn + F2 to activate or diactivate the battery charging mode?

Is that a "battery charging mode" or just a "battery mode?" I was under the impression that it just made my computer run off of the battery or not (when plugged in).

Karosuu

Is a battery charging mode! Is to toggle between the Battery Status Meter, Battery Charge Disable, and Battery Charge Enable feature.