FORUMS

Top Earners This Week
1
thomasoconnell Points: 31 Lv 2
2
Maretoh Points: 22 Lv 30
3
Karkas12 Points: 20 Lv 30
4
KhraFiros Points: 20 Lv 16
5
DjukaDev Points: 20 Lv 24
6
hpeter1 Points: 20 Lv 8
7
ohms_uk Points: 20 Lv 30
8
Fargus007 Points: 19 Lv 18
9
Lögreglan Points: 19 Lv 21
10
Alex1_ Points: 17 Lv 30

Broken daily quest...

  • 30

Click 'Start Quest'

Pops up saying 'Thank you for playing!'

No ARP

Shows up as incomplete under Daily Quests

 

As a new user of Alienware rewards and Dell products, I don't have much hope in this site... I've been on it less than a week, it's very buggy.

The laptop is OK, runs hot... and the Dell laptop software is, suprise suprise, buggy and outdated too!

Replies • 14

I'm having the same issue.  The Daily Quests are not registering as completed for me.


Yea, 2 days now and still no ARP rewarded and it acts like I did not complete it.


Quests only work like half the time in general, it seems. This new site design still bugs the hell out of me, is harder to navigate, and some of it doesn't even work.

 

Both quests today aren't doing anything. Marked as Incomplete, but just say "thanks for playing" or "limit reached."

 

Great job. :/


Both quests not working for me, day 2


me too, not working at all; edit- I just tried Firefox, no go, IE11 didn't work, but Microsoft EDGE did work????  I don't understand

edited

Same issue here, I tried it several times during the day in Firefox and in Chrome (they said that Firefox has problems but Chrome was supposed to work well, well not anymore!). Now at the end of the day finally the points are applied but yeah, this is not good stuff.... Very frustrating and becoming more frustrating to use this new web layout really as it just doesn't work well enough.


Not working on Fire Fox or Explorer.


Still not working here, either.


I'm just getting a small black box for both Firefox and Chrome.


I have been using the app to get it to work and while yesterday even the app quest wasn't working, it worked again today.